竟然犯了个低级错误

时间: 2015-08-22 / 分类: wordpress / 浏览次数: 1,485 views / 0个评论 发表评论

以前用过一个插件是正常的

今天装上以后竟然不能用,看控制台出现Uncaught TypeError: Object # has no method ‘tabs’ 的提示

然后想到了JS冲突,刚好这个插件可以屏蔽掉本身的JQUERY,设置以后还是一样的错误

然后一直查来查去找不到问题

上网一搜,才知道

“出现这种情况,是你引用js的时候。 先引用的插件的js 再引用的jquery吧。 应该先引用jquery 再引用jquery插件。 顺序不要弄错了。”

仔细一看JS,原来我自己引用的jquery 放在了wp_head();后面

WP貌似把JS什么的都放在wp_head();

然后就出现了刚才的错误~

奶奶的~竟然是这么低级的一个错误~

发表评论

你必须 登录后 才能留言!